GNS3と物理ネットワークをトランクで繋ぐ方法

GNS3とCatalyst実機をトランクで繋いでみました。手間取ったので、手順を記録します。

環境は以下の通りです。

Windows 10
GNS3 Version 2.1.0
StarTech.com USB 3.0 LANアダプタ USB31000S
Catalyst 3560 v2

NIC選びと設定

GNS3とCatalyst実機の接続にはUSB-LANアダプタを使いました。ネットでは安くてタグVLANが使える製品の報告もありますが(URL)、「IEEE 802.1Q 対応」を商品紹介で謳っている商品は意外に少なく、次の商品を選びました。

 

タグVLANを使えるようにするために、ドライバをインストール後、設定を変えます。

デバイスマネージャーからAX88179のプロパティを開きます。

 

「詳細設定」タブの「Packet Priority & VLAN」を「Packet Priority & VLAN Disable」にします。メーカーサイトに掲載されている設定です。

 

Winホスト上のNICの名前はわかりやすく「USBLAN-STARTECH」と変えました。

 

Catalyst実機とUSB-LANアダプタをLANケーブルで接続して完了です。

 

GNS3の準備

今回は仮想ルーターを繋いでみます。

 

「Cloud」オブジェクトを配置します。「Cloud」はWinホストのNICとGNS3をブリッジするオブジェクトです。以前のバージョンのGNSでは「Host」という名前でした。

左ペインからCloudをドラッグ&ドロップすると、ホストを聞かれます。Winホストのホスト名を選択します。

 

linkモードでCloudをクリックするとWinホストのNICの一覧が現れます。そこからUSB-LANアダプタを選んだ後、仮想ルーターのポートに接続します。

設定

仮想ルーターにサブインターフェースを作ります。

R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.252 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit
R1(config)#

 

Catalyst でもVLANを割り当て、トランクにします。

SW1(config)#vlan 10
SW1(config-vlan)#exit
SW1(config)#interface vlan 10
SW1(config-if)#ip address 192.168.10.254 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#

 

仮想ルーターからpingを打ってみます。最初は失敗しますが、すぐに成功します。

R1#ping 192.168.10.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 8/17/32 ms

 

GNS3のリンク上のパケットをキャプチャしてみます。

「802.1Q Virtual LAN」というフィールドが見えるので、キャプチャも成功しています。

ちなみにWiresharkの列にある「VID 1q」フィールドは、以下のサイトを参考に表示させています。
http://nwmkmemo.undo.jp/post-26/

おわりに

最初はうまくいかず、悩みました。手持ちのNICが802.1Qに未対応な事が原因でした。

GNS3と実機をトランクで繋げられると、シミュレートできる幅が広がりますね。

コメント

タイトルとURLをコピーしました